Jump to content


Windower causing graphical lag, Hybrid video cards

laglaggyhybridvideowindows 10

    4 replies to this topic

    #1 Patriclis



    • Members
    • Pip
    • 3 posts

      Posted 30 December 2015 - 02:07 PM

      Hello support forum,


      I'm having issues getting windower to run without lag on my laptop. Here are my specs:

      Windows 10
      16GB RAM
      Hybrid Graphics: 

           - Intel HD Graphics 4600

           - Nvidia GeForce 745M 2gb
      Intel i7-4700MQ 2.40Ghz (8 CPUs)


      When running vanilla FFXI I get no lag issues whatsoever, but when running with windower I get -severe- graphical lag (drops to 10FPS in outside zones + towns, or when trusts are out) ... Really the only thing i've been able to do without lag is solo limbus... and even that gets choppy if an avatar is summoned.

      I have:
      - Turned off all shadows
      - Reduced Clipping Plane to the minimum
      - Turned off all 'effects'
      - Reduced characters on screen to the minimum
      - Turned graphics down to 1366x768
      - Turned off super sampling
      - Turned off Bump Mapping
      - Turned off Mip Mapping
      - Turned off HWAcceleration in the registry
      - Set the default graphics card for all programs to be the nvidia card
      - Set the default graphics specifically for ffxi, pol, and windower to be the nvidia card
      - Set drawdistance to 1

      - Downloaded latest video drivers

      - Reinstalled Windower

      And yet despite all this, windower still lags severely... turning off all these options has shown a very minimal improvement, but nothing actually worth talking about (1 maybe 2 FPS)
      Again, running FFXI normally without windower, runs without lag, even on 1920x1080

      I'm not sure what else to do at this point.... I've tried everything I can think of.

      At this point Im assuming windower is not properly using the Nvidia graphics card for some reason... because I had a laptop 3 years ago that did not have a hybrid card, and ran windower with max settings beyond perfectly, and it was nowhere near as good as this current machine. Any help would be appreciated, thank you.

      #2 Patriclis



      • Members
      • Pip
      • 3 posts

        Posted 30 December 2015 - 03:07 PM

        Reinstalled new driver, lag is improved, but still gets bad with trusts or in abyssea

        #3 Iryoku


          Advanced Member

        • Windower Staff
        • 488 posts

          Posted 31 December 2015 - 07:58 PM

          I do think that Windower may be selecting the Intel GPU unintentionally here. I have a pretty good idea about what may be causing this, but I'm not sure how easy it will be to fix.

          #4 modena



          • Members
          • PipPip
          • 28 posts

            Posted 25 January 2016 - 06:27 PM

            If you're still experiencing issues with this then configure your nvidia software tools to specifically utilize your gpu for pol


            Here's a related thread on bg, hope it works out for you


            #5 Daywhite



            • Members
            • PipPip
            • 19 posts

              Posted 27 January 2016 - 03:29 AM

              I had a similar issue, also am using intel hd 4600 but with nvidia 860M


              I guess the intel graphics arent compatible with windows 10, so i had to go back to 8.1, no issues since i reverted

              Also tagged with one or more of these keywords: lag, laggy, hybrid, video, windows 10

              1 user(s) are reading this topic

              0 members, 1 guests, 0 anonymous users